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Xsend Motion

Have you ever wanted to send a project from Final Cut Pro X to Motion 5? Xsend Motion is for you! 
Xsend Motion is an application that reads FCPXML from Final Cut Pro X 10.2 and a later, converting 
the FCPX project into a Motion 5 project. Using Xsend Motion you can quickly send your clip(s) from 
FCPX to Motion and better use the applications together.
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Interface Overview

Xsend Motion translates a Final Cut Pro X XML file into a Motion 5 project. You can use it with an XML 
file you export yourself, or you can use the Share menu in FCPX to send your FCPX project to Motion. 
The application consists of three sections:

1. In the top section choose the FCPXML file to process into a Motion project. If you use the Share 
Menuin FCPX, this will be filled-in for you. 

2. A few options, described in more detail below. 

3. The location where the resulting Motion project is created.
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Source XML

Source XML
The top section of the Xsend Motion dialog is where you supply the XML file from Final Cut Pro X. You 
can export an FCPXML then drag it onto the Source XML field or click the Browser button to navigate to 
the FCPXML. XML exports of Projects and Compound Clips are supported; Event and Library XML files 
not.

If you use the Share menu, the source file section of Xsend Motion will be filled-in automatically.

You can also drag an FCPXML file onto the Xsend Motion icon in the Finder.

Automatically continue from Share Menu
Once you have Xsend Motion set the way you like you may not need to bother with the settings again, 
so having to click Continue in the Xsend Motion interface slows you down. Enable Automatically 
continue translation and the next time you use Xsend Motion from the FCPX Share menu, the current 
settings including the destination folder will be used.
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Settings

Settings
Xsend Motion offers a few settings for controlling the translation.

Create layer groups based on Individual Layers
Xsend Motion offers control over how your clips are grouped in Motion.

When this project is sent to Motion grouping layers by individual clips, each clip becomes its own layer 
group in Motion. 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Create layer groups based on Lanes above/below primary 
storyline
When this project is sent to Motion grouping layers by lanes, clips are grouped in Motion based on the 
clips’ distance from the Primary Storyline in FCPX. FCPX XML defines “lanes” that tells Xsend Motion 
how far above or below the primary storyline a clip or secondary storyline is. With this option, clips are 
grouped together by the lane they’re in.

Create groups for Secondary Storylines
This option groups together clips that were in a secondary storyline. The name of the secondary 
storyline is generated by Xsend Motion based on the sequence time where the

secondary storyline appears. This is to help you identify one secondary storyline from another. If you 
rename the storyline in FCPX, that name is used to as the name of the Motion group.

These groupings do not affect audio layers.

Ignore Audio
Enable this option and Xsend Motion will not create audio layers in the Motion project.

Location of Motion project file
This is the location where your new Motion 5 project will be saved. This location is stored in 
preferences and will automatically appear the next time you use Xsend Motion.
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Share Menu
The easiest and fastest way to use Xsend Motion is directly from Final Cut Pro X using the Share 
menu. When you choose this method, FCPX does an FCPXML export in the background and 
automatically gives the XML file to Xsend Motion.

Only Projects can be sent via the Share menu, at the time of this writing FCPX can not successfully 
“Share” a Compound Clip. If you would like to send a Compound Clip to Motion, you can manually 
export an FCPXML file and open in Xsend Motion.

When you select Xsend Motion from the Share menu you will be presented with an FCPX File Export 
dialog. This dialog has settings for Format and Video Codec as well as a summary of the export 
including an estimated file size. You can safely ignore all of this. Click Next... to proceed and have 
FCPX create XML and launch Xsend Motion. No long export or large files are created, just a very fast 
export of a small XML file.

Installing Xsend Motion into Share menu
The Share menu is a great way to access Xsend Motion and send projects from FCPX to Motion. 
Adding Xsend Motion to the Share menu is easy as this video demonstrates.
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The steps to manually install a Share Menu item are:

1. Open the Final Cut Pro Preferences 

2. Select Destinations tab in the Preferences window 

3. Choose Add Destination from the list on the left 

4. Double-click Export File from the new destination options on the right 

5. Change the Open With... popup to use Xsend Motion. Choose Other... and then select Xsend 
Motion 

6. Rename your new Share Destination “Xsend Motion” 

7. Close the Preferences window

Another method: You can download a setting file from here ; then unzip the file, open the .dmg file,  and 
drag the Xsend Motion.fcpxdest file into the list of Destinations in the FCPX Preferences window. 

(http://www.automaticduck.com/s/Xsend-Motion-Share-Destinationdmg.zip)

A movie is also available within the .dmg for more instruction if needed.

You can also use the Destinations preference panel to reorder the items in the Share menu as you 
wish.
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Duplicate Share Menu entries?
There is a bug in FCPX that will often result in multiple entries of Xsend Motion in the Share Menu. 
Follow these steps to manually remove the share menu items and add just one back.

Share menu and Compound Clips
If you use FCPX’s Share menu to send a project via Xsend Motion, an FCPXML file is written in a folder 
called “Automatic Duck Xsend Motion” located in your User’s Movies folder. These XML files can be 
trashed any time. However if you have a problem and need to contact support, you may need to send 
the XML file from this location.

The Share menu can only be used to send Projects from FCPX, compound clips won’t work. FCPX 
does not warn of you this, so if you try to send a Compound Clip via the Share menu, Xsend Motion will 
give you the following error message...

Instead of using the Share menu with a Compound Clip, select the Compound Clip in the Browser and 
use the File > Export XML... command. Then open that XML file in Xsend Motion by browsing to and 
selecting it or by dragging it into the upper section of the Xsend Motion application.
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What translates from FCPX to Motion

FCPX Feature/Parameter Motion Translation

Audio Fades Audio levels keyframes

Video Fades Opacity keyframes

Audio levels Audio levels

Transform > Position Transform > Position

Transform > Rotation Transform > Rotation

Transform > Scale Transform > Scale

Transform > Anchor Point Transform > Anchor Point

Crop (Trim type supported)† Crop

Distort Four Corner

Spatial Conform Transform > Scale

Compositing > Opacity Blending > Opacity

Compositing > Blend Mode Blending > Blend Mode

Cross Dissolve transition Fade In/Fade Out Behavior

Other transitions All transitions converted to Fade In/Fade Out 
behavior

Retiming (constant speed) Timing > Constant Speed

Retiming (variable) Keyframes in Timing > Variable Speed††

Retiming (hold) Keyframes in Timing > Variable Speed††

Freeze Frame Keyframes in Timing > Variable Speed

Markers Markers

Clip Note Note added as a purple marker

Text generators††† Text generator layers copied into new project

Generators Generator is recreated

Effect > Distort > Flipped Filter > Distortion > Flop

Effect > Color > Colorize Filter > Color Correct > Colorize

These third party effects installed in both FCPX 
and Motion††††

The same filter is applied in Motion
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† Crop types of “Crop” and “Ken Burns” not supported 

†† Video clips only. Motion does not support variable time remapping on audio clips 

††† Multi-line text currently not supported, line endings appear as the “pipe” character: |

†††† See section entitled “Tested third party effects” later in this document
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Keyframes
Position, Rotation and many other parameters can be keyframed and those translate through Xsend 
Motion.

Please note that FCPX can apply easing to keyframes, so that animating layers accelerate in and out of 
a keyframe. Easing is not translated by Xsend Motion.
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Tested third party effects
The following effects or effect suites have been tested with Xsend Motion. Is there a plug-in you would 
like supported? Please let us know.

† plug-in discontinued from FxFactory

†† Layer marker added to show necessary Preset selection  

Boris Boris Continuum Complete

Dashwood Cinema Solutions Editor Essentials

Digital Anarchy Beauty Box, Flicker Free

Nattress Contrast, Levels and Curves, Video Scrapbook

Noise Industries FxFactory Pro

PHYX Cleaner†, Color†, Defocus†, Flarelight†, Glitch†, 
Stylist†

Red Giant Colorista III, Colorista IV

Red Giant Magic Bullet Looks 3, Looks 4

Red Giant Universe (excluding transitions)

Sheffield Softworks Artitude, Look Sweet, Makeup Artist 3, Movie 
Color, Vintage

Yanobox Moods††, Mosaic††
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Compound Clips in your Project
If you send a Project containing a Compound Clip, Xsend Motion will recreate the contents of your 
compound clip in a group layer stored inside a group at the bottom of the project called “Clone 
Sources”. Then a Clone layer is created pointing at the group representing the compound clip. This 
allows a single Compound Clip to be reused multiple times in a project with a single change inside the 
resulting group rippling to other instances. Using a clone layer also makes it possible to apply speed 
changes to the group that represents the Compound Clip.

A side-effect is that clone layers don’t support audio, therefore audio in a compound clip doesn’t play in 
Motion when brought in through Xsend Motion. Audio levels and Audio fades are not translated with 
Compound Clips.
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Disabled clips and effects

Disabled Clips
Clips that are disabled in the FCPX timeline are translated to Motion and the disabled clips appear in 
Motion as disabled as well.

Disabled Effects
Individual filters can be disabled in FCPX, and those filters will be translated into Motion but will be 
disabled. Same with Crop and Distort.

Transforms (Position, Scale, Rotation, etc.) in FCPX can be disabled, but cannot be disabled in Motion, 
so Xsend Motion discards disabled transform values. A marker is added to the clip to warn you about 
the discarded Transform values.
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Markers

Clip markers in FCPX are applied to clips in Motion. Xsend Motion uses Motion’s marker color feature 
to differentiate the kinds of markers coming from FCPX.

Warning marker
When Xsend Motion encounters an effect or parameter that is unsupported, markers are placed in the 
middle of the associated clip. The marker’s comment will tell you what didn’t translate. Double click the 
marker to read the comment.

FCPX Motion
Standard Marker Blue Marker

Unfinished Todo Marker Red Marker

Completed Todo Marker Green Marker

Chapter Marker Orange Marker

Warning marker created by Xsend Motion to 
indicate unsupported feature

Grey Marker

Clip Note  Purple Marker
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If multiple unsupported effects are applied to a clip, Xsend Motion will create multiple warning markers 
on the layer in Motion.
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Effect Image Wells/Drop Zones
Many effects and Generators in FCPX have an Image Well/Drop Zone control where you can add 
media to be used as a separate input. Unfortunately Final Cut Pro X does not export information about 
the media in the image well to XML, therefore Xsend Motion cannot translate this into effects in Motion.
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Transitions

The only transition translated by Xsend Motion is Cross Dissolve. Other transitions are converted to a 
Fade behavior and a warning marker is placed on the timeline to tell you which transition effect had 
been there in Final Cut Pro X.
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Title and Generator Motion Templates used in FCPX
Xsend Motion has limited support for translating titles and generators from FCPX into Motion. While 
Motion is used to create title and generator templates that can be used in Final Cut Pro, Motion itself 
can only open these templates as full projects, with all of the complexity designed into them. 
Experience has shown that for some titles and generators, Xsend Motion can copy the contents of 
these templates into a group in the Xsend Motion-created project, but for many other complex Motion 
templates, copying the contents creates problems including crashing Motion!

As a result, most titles that are processed by Xsend Motion will be converted into a simple title. This 
way you don’t have to re-type your text in Motion, you can copy and paste if you’d like, or otherwise use 
the placeholder text as a starting point.

If your title had multiple text fields, they are combined and separated by the pipe (“|”) character.

Generators in your Final Cut timeline are replaced by a disabled Solid color in Motion and a warning 
marker will be attached to let you know what had been in that spot of the timeline.

If you need to see your complex titles or generators from Final Cut Pro in Motion, an approach may be 
to export the titles and or generators as a separate QuickTime movie with an alpha channel based on 
Roles. Ripple Training did a great movie about this very topic.
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Audio

Audio volumes levels are translated from FCPX to Motion. An important difference to note is that while 
FCPX’s maximum audio level is +12, Motion’s max is +6. Any level over +6 in FCPX will be clamped at 
+6 in Motion. Audio pan is not translated.

Variable speed time remapping also does not apply to audio.
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Canvas View

Depending on your screen size and project resolution you may not see your entire canvas, or maybe 
your canvas will be too small after translation.

You can change the view percentage. Click the Canvas and press Shift-Z on your keyboard to fit the 
view.
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Translate the same project again

It is possible that you might want to translate the same project again after doing it once. If you choose 
the same project to translate into the same destination, Xsend Motion will overwrite the previously-
created Motion project. If you want to keep the older .motn file, rename or move it before redoing the 
translation.

If you have a project open in Motion and translate it again, you may see this dialog. If you click Keep 
Motion Version, the second newer translation will be discarded and the older project will persist. Click 
Revert and the changes in Motion will be discarded and the newer Motion project will be opened.
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Getting back to FCPX

When you’re finished working in Motion and want to return your work to Final Cut Pro X, you have two 
choices. You can publish your Motion project as a generator to be played back directly inside FCPX, or 
you can export a movie from Motion and then import that movie into FCPX like any other movie file. 
Each has advantages and disadvantages, so use the method that works best for you and your project.
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What doesn’t translate?

If it isn’t listed in the What translates from FCPX to Motion page, it may not translate.

We can’t necessarily know all that does not translate, but here is a list of some things we know don’t 
translate through Xsend Motion.

• Color Board

• Stabilization

• Keying effects

• Except for those listed in the table on the page What translates from FCPX to Motion, most built-in 
filters in FCPX don’t translate in Xsend Motion 1.0

• GrowShrink plugin from Alex4D

• A compound clip used as an angle in a multicam clip doesn’t translate properly

• Text from iMovie

◦ It is possible to create animated titles using the Trailer feature in iMovie and then bring those 
into Final Cut Pro X. Unfortunately the files that represent these titles are not compatible with Motion 
and so Xsend Motion cannot pass them along.
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Need Help?

Crash?

If Xsend Motion crashes, the next time it is launched it should detect the previous crash and offer to 
upload your crash log. Please do this. Please include your name, email address, and a description of 
what you did or the project that caused the crash. We receive these crash logs and may contact you to 
get your XML file so we can correct the issue.

Need help? Contact Customer Support
To contact customer support for Xsend Motion, choose Contact Customer Support from the Help menu. 
FxFactory will launch and provide a contact form to describe your issue.
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